Skip to content

ffmpeg x264 settings

Was playing with h264 a bit trying to get good qual low bitrate with ffmpeg. No Love with defaults. So with a little help from google I found something on Doom9.net.

FFmpeg x264 encoding guide

The two pass worked well except for the not liking “rc_eq ‘blurCplx^(1-qComp)'”

So I did a two pass where

x264[1]=”-flags +loop -cmp +chroma -partitions +parti4x4+partp8x8+partb8x8 -me epzs -subq 1 -trellis 0 -refs 1 -bf 3 -b_strategy 1 -coder 1 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -bt 300k -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4″

x264[2]=”-flags +loop -cmp +chroma -partitions +parti4x4+partp8x8+partb8x8 -flags2 +mixed_refs -me umh -subq 5 -trellis 1 -refs 5 -bf 3 -b_strategy 1 -coder 1 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -bt 300k -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4″

and then looped ffmpeg with
for p in 1 2 ; do ffmpeg -i /mnt/Mp3/Mp3/Images/ClubMed2006/CIMG0405.AVI ${x264[p]} -s 320×240 -b 300k -ab 48k -pass $p -y CIMG0405p1.flv ; done

With -b 280 I go a good video at 325kbps?

Next I tried no scaling so video is 640×480 at 343.4kbits/s

The only problem I see is grey video at the start

Advertisements
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: